Resolved
The incident has now been resolved and we are back to normal operation
Identified
We have identified the root cause and are actively working on a resolution.
Investigating
Customers might experience PowerPDF Portal availability issues, we are actively looking into the issue.