Resolved
The issue is resolved and all services are operational.
Monitoring
A fix has been implemented and we are monitoring the results.
Investigating
We are aware of an issue with slow processing of documents in the EU region and are currently investigating.