·
Write-up published
Read it here
Resolved
The Capture service issue has been resolved.
Monitoring
We are aware of an issue with Capture delays. We have already scaled up the service and customers should be seeing improvements.